AL JAZEERA ENGLISH has MOVED in SOME AREAS on 20 AUG

Welcome to the Freeview Forum

Forum

Reception and Technical Issues

Qs about reception. Lost channels? RETUNE advice? Blocks on the screen? AV sync issues? Go here.

347 discussions

Freeview equipment

For all your discussions on Freeview equipment like recievers, aerials etc. What is the best to buy for my situation?

43 discussions

GET FREEVIEW - Equipment & Set Up

For all your discussions on setting up and installing Freeview such as how do i install a Freeview reciever or i want to set up Freeview in 2 rooms?

66 discussions

How to use Freeview

For all your discussions on how to use Freeview such as how do i use the EPG? or Freeview +?

15 discussions

Videos

  • Add Videos
  • View All
 
 
 

Connect With Us!

Latest Activity

willis replied to Max Edge's discussion Dealing with Hills Signalmaster over a faulty freeview box
"hills has always been an australian company hills industries pty  until fairly recently when…"
10 hours ago
Anna GRay posted a discussion

freezing tv3 and channel four only

I have a t1050.Tv3 and channel 4 including the plus 1's are freezing. I noticed this on Tursday. I…See More
16 hours ago
Dish TV Support replied to William Petty's discussion prime
"Hi Bill The next thing we could try is a firmware update, Have you had a look at upgrading your…"
19 hours ago
William Petty replied to William Petty's discussion prime
"No prime froze while I waswatching it It was TVone that I had programmed to start at 7.30 When the…"
21 hours ago
Dish TV Support replied to William Petty's discussion prime
"Opps, looks like that's the wrong information. If you can go to a Prime recording…"
21 hours ago
Angela Shivnan replied to Graeme Dearness's discussion Signal level differences on FreeviewHD
"Hi Graeme Did you ever get an answer to this question so that you could resolve it? Think I have…"
23 hours ago
William Petty replied to William Petty's discussion prime
"Video 515 mpeg2-sD 720x576 25fps 1.78mbps 1.78mbps Audio 653 MPEG 0.02kbps Optus d1…"
yesterday
Robert Hepple replied to Ian Mallett's discussion Panasonic DMR-XW390 pixelating on all channels
"Doing that with the plug or adding an attenuator is showing there is an issue with a higher signal…"
yesterday

© 2014   Created by Bel.   Powered by

Badges  |  Report an Issue  |  Terms of Service