I have an 8 year old Panasonic Freeview recorder (DMR-XW380) and for some time the UHF signal has been pretty bad with massive picture break up.

So when the aerial came down earlier this year the old man replaced it with a newer one and it was okay (not perfect) for my dad who was running a Dish TV T1020 receiver in his bedroom off a splitter which we were both connected to.

There was still, on his machine, moments where the picture would freeze and so forth and on mine I couldn't do much with it but now he has a Sky box through Multiroom.

It should be noted that the splitter is over 20 years old and has pretty much rusted.

So when he got that I took the aerial and plugged it directly into my recorder and for the past month or thereabouts it was pretty much fine but in the last few days my picture has gone back to the way it was before and the only solution I have is to plug the aerial directly into my new Smart TV where it's picture perfect.

So could our STB's of 7-8 years in age have gone faulty or is it possible there is still an underlying issue.

The only problem in getting a serviceman out is that with the roof in bad condition the old man won't let anyone onto it so I need solutions that won't require a serviceman to go up there.

Views: 160

Reply to This

Replies to This Discussion

It's unlikely to be the Panasonic or STB. Normally they either work or they don't.

The problem is almost certain to be associated with the antenna and cabling. And if the splitter is that old then it's most likely to be the wrong type i.e. an old one suitable for VHF analogue. For UHF you need a good quality splitter with f type sockets.

Hey Damien, sorry for a bit of a late reply...

I was thinking the same as Biggles, but then I read it again and you said you plugged the cable straight into your new Smart TV and it was all ok. I assume no more splitter then?

If I assume the splitter was not in when you were working with your old DMR? If so and the picture was ok at first and now no longer, it could be that the aerial has shifted a bit? As the new Smart TV is probably more sensitive, it could be that the signal is just still strong enough for the TV. Check the direction of your neighbour's aerials and see if it lines up.

Sometimes a reset of the unit works too - make sure you choose the proper type of reset at it might wipe your recorded shows.

If the aerial does line up, it could be corrosion in the cable connection to the aerial?

Not sure if you're near a transmitter tower, but you might be able to get a small aerial and use it indoors??

Just thinking something else: not sure if you're near another TV tower (like I am) and there are stronger signals to be found. You could make your box update the channels and see if that helps. If you do, put the splitter in, so it will not find the weaker stations.

Good luck, let us know how you go!

Bart

Reply to Discussion

RSS

Latest Activity

David Lipscombe replied to David Lipscombe's discussion Slow TV Prime
"Thank you Biggles I looked at their website and they only had the 3hr version . I then contacted…"
2 hours ago
Lennard Haynes posted a discussion

Tv on demand

Hi my S8200 since a year or so ago has never worked properly after you changed to the new TV guide…See More
5 hours ago
Biggles replied to Brian Sargeant's discussion CHOICE TV
yesterday
Biggles replied to AM's discussion Freeview setup: converter box from satellite to aerial
"You need a UHF box to replace your Sat box. Or a new TV."
yesterday

Connect With Us!

© 2019   Created by Bel @ Freeview.   Powered by

Badges  |  Report an Issue  |  Terms of Service