Hi all,

I have a Homecast HT9200DTR and it has started playing up! I can switch it off on the remote but not on. The blue lights around the manual on / off button and the volume / menu dial stays on when it is switched off. When I manually switch it on, it goes through quite a long sequence before I can get a picture. Sometimes it re-tunes itself, sometimes sub titles appear even though I have them set off, sometimes I get a black and white screen!!

Any help to get back to 'normal' would be great!

Views: 1650

Replies are closed for this discussion.

Replies to This Discussion

Have you tried a cold start? i.e. Disconnect from power source, wait about 30 secs and reconnect.

I have a media player does this sort of thing occasionally. A cold start always restores normal operation.

Yes - I have left the power off for a few minutes and switched on again, - no difference. Left it off over night - no difference. 

I would try to re-set to factory default but it asks for a password. I have never put a password in and I read that the standard one is 0000, I have tried this but it says it is invalid. Not sure what to do with it now!! Does anyone know why the blue lights stay on when my machine is off?

The latest thing it does now is wait 200 minutes before switching off after recording. It has set itself to the maximum time! If I could get it  re-set to factory default setting - I should be right, but I cannot get past this password rubbish. 

You could try updating the firmware and hope it deletes the password.

or

Try asking on the Support Forum if you can override the default password.

Homecast HT9200DTR MyFreeview|HD Support here

RSS

UPDATES

  • OnDemand Issues for SAMSUNG SMART TV
    We are aware of issues with these TVs, It is under investigation.  Please check NETWORK STATUS for the latest updates. 

    If you post regarding this, please include your Model Number which can be found in the Menu or the back of your TV. 

Connect With Us!

Be a part of the New Zealand Freeview Community!

Welcome to your Freeview Forum!  This is the online home for all Freeview viewers, retailers, manufacturers and installers. It's a place where you can find help, share advice, tips and your know-how to help another fellow "Freeviewer" out.

How do I get started?

1. Begin by signing up for Freeview Forum here.  Sign up is simple, fast & free, all we ask is that you abide by a few simple guidelines.

What details should be included when asking for help?

Including key details will help the community help you.....

1. What your coverage is (check by entering your full address here).

2. What antenna you're using (indoor of outdoor UHF aerial, or satellite dish).

3. What brand & model your device is.

4. What channels or programmes you're having trouble with (if any).

5. And of course - as many other details as you think would be relevant.

© 2020   Created by Bel @ Freeview.   Powered by

Badges  |  Report an Issue  |  Terms of Service