Hi,

I have had the help of Dish TV to get my SatBox S8200 upgraded and working (hopefully) to its potential.

So when they got me upgraded via a USB Freeview plus also loaded. This is great, as I would love to be able to use this feature, and I can navigate my way around the Mini Guide / Menu and get into the catch-up guide. However,  there are a couple of problems:

1. When I get into the catch up guide and select a programme (that was available on Demand, as it was showing the symbol that indicated this service) - all  that happened was a spinning arrowed icon in the bottom left hand corner ... for ages, and nothing else.

2. When I get into the On Demand page from the menu it is blank - there are no apps to select, what's happening ??

On a high note it seems as if things are moving forward with our SatBox and Freeview, and for this I am really happy.

Regards, Gwenyth

Views: 191

Reply to This

Replies to This Discussion

Hi 

You will need to be connected to the Internet in order for FreeviewPlus to work, you can do this via the Installation Section in the Menu to set up a WIFI connection or plug the cable from the router or modem into the back of the set top box. 

Regards,  Josh

Reply to Discussion

RSS

Connect With Us!

Latest Activity

Paul replied to david adamson's discussion Distorted image from Veon SAT101
"Hi David I have the Veon 101 connected to a 42 inch Samsung (Plasma )via hdmi  and don't…"
13 minutes ago
david adamson posted a discussion

Distorted image from Veon SAT101

Hi All.I have a Veon SAT101 receiver. I have noticed some picture distortions…See More
1 hour ago
Beth Emerre replied to Beth Emerre's discussion Lost all signal
"I've got Ultraplus 700hdmi"
yesterday
Beth Emerre posted a discussion

Lost all signal

I'm hoping someone can help...last Tuesday the area had two consecutive power cuts and since then…See More
yesterday
Patrick Mckibbin replied to Patrick Mckibbin's discussion New S7070rHD-XM does not get a signal - HELP
"Thanks Biggles and Josh Hill. Tried that and unfortunately did not work.  Looks like I am…"
yesterday
Biggles replied to Patrick Mckibbin's discussion New S7070rHD-XM does not get a signal - HELP
"Josh beat me to it. Needs to be changed to 10750/10750. Hopefully it will work then. I'm…"
yesterday
Josh Hill replied to Patrick Mckibbin's discussion New S7070rHD-XM does not get a signal - HELP
"Hi patrick,  Head back to the first menu in your first image and press the blue button, that…"
yesterday
Patrick Mckibbin replied to Patrick Mckibbin's discussion New S7070rHD-XM does not get a signal - HELP
"Thanks Biggles, Have uploaded two photos of the system trying to do its thing. Looks like the 11300…"
Wednesday

Upcoming Works

© 2017   Created by Bel.   Powered by

Badges  |  Report an Issue  |  Terms of Service