Hi. My 9 month-old Freeview Set Top Box (AerailBox model T2100) now responds very slowly, or not at all, to the remote button commands. It seems to be failing gradually.

The menu comes up when the middle 'OK' button is first pressed but then won't respond to any button.

Does anyone have any ideas what causes this and what to do about it?

I've renewed the remote batteries, so I'm assuming that's not the issue.

Do these devices wear out, or be faulty sometimes?

Do they have a warranty? If so who can I return it to?

Advice appreciated!

Views: 115

Reply to This

Replies to This Discussion

Hi Dharan, 

Dish TV Support should be responding to this query shortly (Within the next few working days). If you don't hear from them.We recommend contacting them directly via their website www.dishtv.co.nz 

Cheers
Josh

Cheers - thanks Josh.

Reply to Discussion

RSS

Latest Activity

David B replied to Jared's discussion tvnz ondmend
"It's a 43W800C"
6 minutes ago
Bel @ Freeview replied to Jared's discussion tvnz ondmend
"Thanks David - great to know the update did the trick for ya. Will share the auto-update fail with…"
8 hours ago
Satellite Networks Motueka replied to David Edmunds's discussion powering LNB
"Thats a 3x4 multiswitch not a splitter. Use the 18v port and dont turn off the LNB power in the…"
16 hours ago
Satellite Networks Motueka replied to Tim Eaden's discussion Freeview Ondemand freezes on Samsung TV
"Could be 1 of several things. Firsty whats your internet speed like? Ondemand hasn't got the…"
16 hours ago

Connect With Us!

© 2018   Created by Bel @ Freeview.   Powered by

Badges  |  Report an Issue  |  Terms of Service