Freeview on demand not working on Philips 55” 4k Smart TV

I just purchased the Philips 55” smart tv purposely for the face it’s compatible with Freeview on demand. Apparently a prompt is suppose to appear in the top left corner for Freeview on demand & I press the green button to activate this, however no prompt is appearing. I’ve tried everything the instructions both online & in the manual are saying however nothing is working. Please help!

Views: 389

Reply to This

Replies to This Discussion

That seems to be different to what it says here.

https://freeviewnz.tv/freeview/all-new-on-demand/

I don't have a SMART TV but it seems to me that On Demand and Live TV etc are all available via an on screen menu as in the link above. I think the green button method was for the old Freeview plus system.

Thanks for your reply. Green button method is for all smart tvs. Freeview on demand demand is definitely available on my Philips tv as per link, however nothing is working. Harvey Norman are sayings it could be a fault so have sometime coming to have a look hopefully today. https://freeviewnz.tv/get-freeview/approved-products/?categoryId=26

OK. Hope they get it sorted. Let us know what was wrong once it's sorted. Might help others later on.

Calli said:

Thanks for your reply. Green button method is for all smart tvs. Freeview on demand demand is definitely available on my Philips tv as per link, however nothing is working. Harvey Norman are sayings it could be a fault so have sometime coming to have a look hopefully today. https://freeviewnz.tv/get-freeview/approved-products/?categoryId=26
There is a setting you have to turn on. It is under networks most of the time.
Is that the hbbtv setting or something along those lines? I have tried everything under the sun. Two seperate Technicians from Harvey Norman came out to try and solve the problem to no avail. Philips themselves don’t know what’s wrong. Everyone seems to be stumped. Last option is to update the software via USB, so am waiting for Harvey Norman to get back to me regarding that. If that doesn’t solve the problem then I have no option but to return tv and be refunded as it Seems to be a fault with the tv itself

Have you tried the Smart TV Button?

I bought a Philips 4K tv 2 years ago and had a similar issue. The store talked to Philips and they eventually came back saying the hbbtv system is incompatible with the NZ system. It would work in Australia. I actually returned the tv and purchased another (Sony) which works fine. I was hoping for a firmware update to fix it as I loved the tv in other repects, especially the Ambilight. Hope you get it resolved
Cliff
Thank you so much for your reply Cliff. The best answer I’ve had so far, from all avenues as I still haven’t heard back from Harvey Norman regarding software update or Philips. That definitely makes sense & im guessing I’ll have to return and do the same. Will definitely contact Harvey Norman tonight if I haven’t heard anything and inform them of your experience as I feel my situation will be the same issue. Cheers!

That sounds to me like they don't have any idea what hbbtv is. It's an international protocol that works worldwide. If the TV has hbbtv activated it will work anywhere. It does need an antenna connected to the TV though so you can interact with the EPG.

https://en.wikipedia.org/wiki/Hybrid_Broadcast_Broadband_TV

P.S. If the TV's hbbtv is incompatible with the NZ system then the TV is not fit for purpose and in accordance with the CGA it shouldn't be on sale in NZ. Presumably HN have sold more than one Philips TV and not just to you. I'd suggest you ask them if any  other customers have had any problems with theirs?

P.P.S. Before you get a replacement ask for an in-store demo to make sure it works before purchase.

Cliff Baker said:

 The store talked to Philips and they eventually came back saying the hbbtv system is incompatible with the NZ system. It would work in Australia.

Thanks for your help biggles :) will definitely look into that further if it eventuates. Cheers for all your help.
UPDATE: Just incase anyone else runs into this issue. Tv had to be returned as HN couldn’t solve the issue & im guessing it would have been the same as Cliffs (Hbbtv not compatible in NZ), however HN didn’t say that was why. Have just set up my new LG UHD 4K smart tv and it is amazing. Easy and instantly connected to everything it said it would. Will not be purchasing Philips products again.

Reply to Discussion

RSS

OUTAGE ALERT:

All  Systems Go!

Latest Activity

Biggles replied to Damien Service's discussion Problem with UHF signal
"It's unlikely to be the Panasonic or STB. Normally they either work or they don't. The…"
5 hours ago
Damien Service posted a discussion

Problem with UHF signal

I have an 8 year old Panasonic Freeview recorder (DMR-XW380) and for some time the UHF signal has…See More
22 hours ago
Robyn Wilson posted a discussion

Series view

My recordings are coming up as single view, when I hit series view, one single recording comes up.…See More
Sunday
Andrew Weir replied to Andrew Weir's discussion Fitzherbert CH33 570MHz no longer transmitting?
"Looks like the fantastic Welly weather today meant they got up the tower OK. As of this afternoon,…"
Friday

Connect With Us!

© 2018   Created by Bel @ Freeview.   Powered by

Badges  |  Report an Issue  |  Terms of Service