Hi, I am having trouble adding a an extra tv in my house. Brought a 2 way splitter 0-1000mhz. They are freeview TV's and work individually plugged into aerial cable but when turning one on the other one goes distorted. Do I need a better splitter? Cheers

Views: 336

Reply to This

Replies to This Discussion

Can you take a photo of the splitter or confirm if the splitter label reads ALL PORTS POWER PASS  or if you have one that says ONE PORT POWER PASS 

Cheers

Josh

This is what the shop said would be suitable but thinking its not....

go get an amplified splitter

Thanks, Will do when shops reopen!



willis said:

go get an amplified splitter

is there an update to this as I am having this issue with ours and we have 2 TV's with 2 freeview boxes on a 8 way splitter in a 2 storey house, if one freeview is turned off it the other won't go just says the no Signal so have to have both on for the TV to work downstairs, if both TV's and  freeview boxes are on the downstairs TV crackles and pixilates, is there a way to stop this happening... had a similar problem in our last house and had a booster put in, would we need to do the same again ....photo of the 8 way splitter

Hi, haven't had a chance to get someone out but been told need amplified splitter but could also be quality of existing cable in the house. If it pixalates have just been unplugging the aerial from back of TV and replugging and seems to be working. Technology so annoying at times!

ok, thank you

Reply to Discussion

RSS

NETWORK STATUS ALERTS

All platforms working normally.

 See Network Status for more info and updates.

Quick Links

© 2021   Created by Bel @ Freeview.   Powered by

Badges  |  Report an Issue  |  Terms of Service