My DishTV T1050PVR is doing OK on TV1 - TV3 but Choice is very bad. If I play with the power in cord at the back I can sometimes get it to go but sometimes I get just the picture and not the sound and other times the lock light flickers and I keep missing bits . I tried a different power cable but it didnt help at all. Any ideas?

Views: 136

Reply to This

Replies to This Discussion

It could be related to your UHF aerial, it could be misaligned and out of direct sight from your local transmitter. This often reduces the reception quality on some channel groups. 

You could at first, try a retune and see if the channel loads up without any interference, otherwise you may need to get someone to realign your aerial. 

Reply to Discussion

RSS

Connect With Us!

Be a part of the New Zealand Freeview Community!

Welcome to your Freeview Forum!  This is the online home for all Freeview viewers, retailers, manufacturers and installers. It's a place where you can find help, share advice, tips and your know-how to help another fellow "Freeviewer" out.

How do I get started?

1. Begin by signing up for Freeview Forum here.  Sign up is simple, fast & free, all we ask is that you abide by a few simple guidelines.

2. Once you've signed up, you'll be able to:

What details should be included when asking for help?

Including key details will help the community help you.....

1. What your coverage is (check by entering your full address here).

2. What antenna you're using (indoor of outdoor UHF aerial, or satellite dish).

3. What brand & model your device is.

4. What channels or programmes you're having trouble with (if any).

5. And of course - as many other details as you think would be relevant.

© 2019   Created by Bel @ Freeview.   Powered by

Badges  |  Report an Issue  |  Terms of Service