Hi, been having trouble viewing on demand programs, when I select an episode it keeps loading!
Internet connection is fine. Any ideas??

Views: 283

Reply to This

Replies to This Discussion

Did you fix this, we are having the same problem, have restarted, logged out and back in... cleared browsing history
Nope been 3 weeks! Free view are apparently investigating the problem...
OK, i just reset my whole device back to factory settings and it fixed it... we have on demand again
Really, did you reset your tv?

Reply to Discussion

RSS

Connect With Us!

Be a part of the New Zealand Freeview Community!

Welcome to your Freeview Forum!  This is the online home for all Freeview viewers, retailers, manufacturers and installers. It's a place where you can find help, share advice, tips and your know-how to help another fellow "Freeviewer" out.

How do I get started?

1. Begin by signing up for Freeview Forum here.  Sign up is simple, fast & free, all we ask is that you abide by a few simple guidelines.

2. Once you've signed up, you'll be able to:

What details should be included when asking for help?

Including key details will help the community help you.....

1. What your coverage is (check by entering your full address here).

2. What antenna you're using (indoor of outdoor UHF aerial, or satellite dish).

3. What brand & model your device is.

4. What channels or programmes you're having trouble with (if any).

5. And of course - as many other details as you think would be relevant.

© 2019   Created by Bel @ Freeview.   Powered by

Badges  |  Report an Issue  |  Terms of Service