For several months I have not used my second TV which works through the aerialBox-mini T1000, and now I find the set top box is no longer working - the power light just emits a flashing green light, and there is no picture on the TV. I understand now that's probably because I needed to turn off the set top box and unplug it from the power source if it was going to be unused for a long period. Is there any way of restoring its function or should I just ditch it and buy a new one?

Views: 241

Reply to This

Replies to This Discussion

Dish TV are the people to go to for support about that particular device. They will be able to assist with anything about the T1000.

Thanks for your advice. I decided to upgrade to the T2200 anyway. I think the T1000 has had it.

Josh Hill ✔️ said:

Dish TV are the people to go to for support about that particular device. They will be able to assist with anything about the T1000.

Reply to Discussion

RSS

Latest Activity

Biggles replied to William Petty's discussion Red vertical line on tv screen
"Where? I haven't seen any photo. It needs to be posted in the Forum so we can all see it."
15 hours ago
William Petty replied to William Petty's discussion Red vertical line on tv screen
"Hi Bggles I sent you a photo the other day"
17 hours ago
Bel @ Freeview posted a discussion

The Edge TV moving to Freeview channel 14

From this Thursday, The Edge TV will be coming to you on Freeview channel 14.What do you need to…See More
18 hours ago
Biggles replied to William Petty's discussion Red vertical line on tv screen
"How wide? Whereabouts on screen? All inputs or just TV? Picture?"
Sunday

Connect With Us!

© 2018   Created by Bel @ Freeview.   Powered by

Badges  |  Report an Issue  |  Terms of Service