For several months I have not used my second TV which works through the aerialBox-mini T1000, and now I find the set top box is no longer working - the power light just emits a flashing green light, and there is no picture on the TV. I understand now that's probably because I needed to turn off the set top box and unplug it from the power source if it was going to be unused for a long period. Is there any way of restoring its function or should I just ditch it and buy a new one?

Views: 486

Reply to This

Replies to This Discussion

Dish TV are the people to go to for support about that particular device. They will be able to assist with anything about the T1000.

Thanks for your advice. I decided to upgrade to the T2200 anyway. I think the T1000 has had it.

Josh Hill ✔️ said:

Dish TV are the people to go to for support about that particular device. They will be able to assist with anything about the T1000.

Reply to Discussion

RSS

Latest Activity

Connect With Us!

Be a part of the New Zealand Freeview Community!

Welcome to your Freeview Forum!  This is the online home for all Freeview viewers, retailers, manufacturers and installers. It's a place where you can find help, share advice, tips and your know-how to help another fellow "Freeviewer" out.

How do I get started?

1. Begin by signing up for Freeview Forum here.  Sign up is simple, fast & free, all we ask is that you abide by a few simple guidelines.

2. Once you've signed up, you'll be able to:

What details should be included when asking for help?

Including key details will help the community help you.....

1. What your coverage is (check by entering your full address here).

2. What antenna you're using (indoor of outdoor UHF aerial, or satellite dish).

3. What brand & model your device is.

4. What channels or programmes you're having trouble with (if any).

5. And of course - as many other details as you think would be relevant.

© 2019   Created by Bel @ Freeview.   Powered by

Badges  |  Report an Issue  |  Terms of Service