For several months I have not used my second TV which works through the aerialBox-mini T1000, and now I find the set top box is no longer working - the power light just emits a flashing green light, and there is no picture on the TV. I understand now that's probably because I needed to turn off the set top box and unplug it from the power source if it was going to be unused for a long period. Is there any way of restoring its function or should I just ditch it and buy a new one?

Views: 282

Reply to This

Replies to This Discussion

Dish TV are the people to go to for support about that particular device. They will be able to assist with anything about the T1000.

Thanks for your advice. I decided to upgrade to the T2200 anyway. I think the T1000 has had it.

Josh Hill ✔️ said:

Dish TV are the people to go to for support about that particular device. They will be able to assist with anything about the T1000.

Reply to Discussion

RSS

Latest Activity

Russell Clarke replied to Russell Clarke's discussion Samsung 55" Ultra HD 4K Smart LED Television
"Its already all connected, it seems odd that the FV app is so picky as to require a specific…"
Saturday
david adamson posted a discussion

Prime tv and other channels gone

First symptom was Parliament TV turning up on the Choice T channel.  Could not tune in Choice TV…See More
Friday
Peter Vickery posted a blog post
Friday
Dean replied to Linda Taiapa's discussion On Demand Log On
"We've been experiencing this ever since the upgrade as well. For all the hype about it I…"
Thursday

Connect With Us!

© 2018   Created by Bel @ Freeview.   Powered by

Badges  |  Report an Issue  |  Terms of Service