I have a Sony KD-65X7500D tv and on demand hardly ever works.  It plays the first ad but then just has the loading circle.  I've emailed about this a couple of times but get a standard reply of we've passed this onto the technical team.  It doesn't work on any of the available channels and it's the same for any program we try to watch.  My TV is up to date and I did read on another post that there was an update available to download onto a USB but it wasn't for my model of TV.  It's been like this for well over a month now and is super frustrating!!!

Views: 479

Reply to This

Replies to This Discussion

I think it comes down to the DRM protection on demand use.

You tube is free so don't bother with protection.

Netflix you have their own protection system and have obviously come to an arrangement with Sony.

Sony need to update their browser but they perhaps see on demand in NZ a small market not worth the effort.

Reply to Discussion

RSS

Latest Activity

Scott Brown posted a discussion

Help! Satbox S8200 Bootlooping

Can anyone tell me if there is a cure for a Satbox  that suddenly takes hours to boot, then loads…See More
18 hours ago
Russell Clarke replied to Russell Clarke's discussion Samsung 55" Ultra HD 4K Smart LED Television
"Its already all connected, it seems odd that the FV app is so picky as to require a specific…"
Saturday
david adamson posted a discussion

Prime tv and other channels gone

First symptom was Parliament TV turning up on the Choice T channel.  Could not tune in Choice TV…See More
Friday
Peter Vickery posted a blog post
Friday

Connect With Us!

© 2018   Created by Bel @ Freeview.   Powered by

Badges  |  Report an Issue  |  Terms of Service