New Freeview On Demand app - epic fail on my Sony Smart TV

I purchased a Sony KDL-32W600D smart TV  specifically to watch Freeview On Demand. It used to work with the old app, but had freezes once or twice during the programme. However, since the new app was released last year and my TV updated to it, I can 'watch' a minute or maybe two on a good day, or maybe 6 seconds before playback freezes. It is now so bad that it even freezes on the adverts which until now were always played perfectly. It is also crashing my TV - freezes on black screen and no controls work so I have to reboot - switch off, unplug, wait 10 mins and then plug in and turn power on. The TV controls are restored but On Demand is still as bad as ever. Same with refreshing internet content. This has no effect. Factory resets, which Freeview assured me would fix it, also do not work. I have contacted Freeview on numerous occasions, and their solution has been to reboot or factory reset. Sony has been more helpful, but also suggested reset as a last resort. My TV is running Linux. Is there anyone out there who has had the same issues with the new app? Does anyone have any suggestions, aside from buying a new TV or Chromecast, etc.?

Views: 126

Reply to This

Replies to This Discussion

Does the issue only appear on Freeview OnDemand, have you tried the other apps like Netflix and YouTube to see if the issue is isolated to only one app or multiple? 

You can log an enquiry via the website here https://www.freeviewnz.tv/support/contact-us/new_freeviewod_form/ 

Please provide as much info as possible, 

Josh

Hi Josh, thank you very much for your suggestions. I only have issues with Freeview On Demand. Everything else is working fine. I also have no streaming issues as I have fibre and an ethernet cable connected to my TV. So no WiFi  problems either. I have also been in contact with Freeview on numerous occasions, and have provided way too much detail, with no real solution provided from them  so far. As previously mentioned, the only fix suggested by Freeview support is to do a factory reset, which I have done several times with no change at all to my On Demand issues. I still can't watch anything for more than a minute or two. I am awaiting their reply to my most recent completion of their form. Everything points to the app being the problem, because as many other people have found, it only became unwatchable after it updated to the new app. It was the only change to my TV.

Hi Julie, 

Are you able to provide me the model number of the TV? This is usually on the back of the TV and also the serial Number? 

Thanks 

Josh

Julie S said:

Hi Josh, thank you very much for your suggestions. I only have issues with Freeview On Demand. Everything else is working fine. I also have no streaming issues as I have fibre and an ethernet cable connected to my TV. So no WiFi  problems either. I have also been in contact with Freeview on numerous occasions, and have provided way too much detail, with no real solution provided from them  so far. As previously mentioned, the only fix suggested by Freeview support is to do a factory reset, which I have done several times with no change at all to my On Demand issues. I still can't watch anything for more than a minute or two. I am awaiting their reply to my most recent completion of their form. Everything points to the app being the problem, because as many other people have found, it only became unwatchable after it updated to the new app. It was the only change to my TV.

Reply to Discussion

RSS

© 2019   Created by Bel @ Freeview.   Powered by

Badges  |  Report an Issue  |  Terms of Service