We have had this box for a couple of years, it's been in storage for about a year as we tried Sky but now we've ditched that and gone back to this box - I had forgotten how utterly annoying it  is. Above all ,it won't record anything I've put on series link - it just keeps saying FAILED and I literally have no idea why. I've done a factory reset and that's all. I need help, before I throw it out of the window....cheers

Views: 86

Reply to This

Replies to This Discussion

Try going to the DishTV website and downloading the latest firmware..

Firmware may need to be updated Melissa, you can find the latest software updates here https://dishtv.co.nz/downloads  

If you need help, the DISH TV team will be able to assist over the phone or via email.

Josh

Thanks both, I'll give that a go now :-)

Do let us know how you get on

Josh

Reply to Discussion

RSS

Connect With Us!

Be a part of the New Zealand Freeview Community!

Welcome to your Freeview Forum!  This is the online home for all Freeview viewers, retailers, manufacturers and installers. It's a place where you can find help, share advice, tips and your know-how to help another fellow "Freeviewer" out.

How do I get started?

1. Begin by signing up for Freeview Forum here.  Sign up is simple, fast & free, all we ask is that you abide by a few simple guidelines.

2. Once you've signed up, you'll be able to:

What details should be included when asking for help?

Including key details will help the community help you.....

1. What your coverage is (check by entering your full address here).

2. What antenna you're using (indoor of outdoor UHF aerial, or satellite dish).

3. What brand & model your device is.

4. What channels or programmes you're having trouble with (if any).

5. And of course - as many other details as you think would be relevant.

© 2019   Created by Bel @ Freeview.   Powered by

Badges  |  Report an Issue  |  Terms of Service