My DishTV T1050PVR is doing OK on TV1 - TV3 but Choice is very bad. If I play with the power in cord at the back I can sometimes get it to go but sometimes I get just the picture and not the sound and other times the lock light flickers and I keep missing bits . I tried a different power cable but it didnt help at all. Any ideas?

Views: 70

Reply to This

Replies to This Discussion

It could be related to your UHF aerial, it could be misaligned and out of direct sight from your local transmitter. This often reduces the reception quality on some channel groups. 

You could at first, try a retune and see if the channel loads up without any interference, otherwise you may need to get someone to realign your aerial. 

Reply to Discussion

RSS

Latest Activity

Richard Warlow posted a discussion

Panasonic DVR Recorders - Loading Problem

I was wondering when the loading problem is going to be fixed on the Panasonic DVR Recorders?There…See More
17 hours ago
Cliff Baker replied to Cait's discussion Freeview on demand no longer working
"Also on the Network status page "
22 hours ago
Cliff Baker replied to Cait's discussion Freeview on demand no longer working
"Same problem with my 2015 Sony Android tv. From geekzone there is a problem with the On Demand app…"
23 hours ago
Biggles replied to Kane's discussion No TV1 TV2 Duke or Prime
"Try Manual Tune on the appropriate MUX and check signal strength. Most likely an antenna/cabling…"
23 hours ago

Connect With Us!

© 2018   Created by Bel @ Freeview.   Powered by

Badges  |  Report an Issue  |  Terms of Service