Hi. My 9 month-old Freeview Set Top Box (AerailBox model T2100) now responds very slowly, or not at all, to the remote button commands. It seems to be failing gradually.

The menu comes up when the middle 'OK' button is first pressed but then won't respond to any button.

Does anyone have any ideas what causes this and what to do about it?

I've renewed the remote batteries, so I'm assuming that's not the issue.

Do these devices wear out, or be faulty sometimes?

Do they have a warranty? If so who can I return it to?

Advice appreciated!

Views: 167

Reply to This

Replies to This Discussion

Hi Dharan, 

Dish TV Support should be responding to this query shortly (Within the next few working days). If you don't hear from them.We recommend contacting them directly via their website www.dishtv.co.nz 

Cheers
Josh

Cheers - thanks Josh.

Reply to Discussion

RSS

Latest Activity

Graham Syder replied to Graham Syder's discussion is there UHF in Puponga?
"Excellent feedback guys, I'm off over there for the weekend. I don't have a mast to…"
2 hours ago
Satellite Networks Motueka replied to Graham Syder's discussion is there UHF in Puponga?
"Willis is right and you dont need a high gain antennae.The coverage map is so flawed. There is no…"
14 hours ago
Biggles replied to Graham Syder's discussion is there UHF in Puponga?
"Well it does according to it's coverage map. East side of Arapawa Is shows good reception…"
14 hours ago
willis replied to Graham Syder's discussion is there UHF in Puponga?
"signal probably Mt Campbell as kaukau doesn't go west"
17 hours ago

Connect With Us!

© 2018   Created by Bel @ Freeview.   Powered by

Badges  |  Report an Issue  |  Terms of Service